penguin.jpeg

ThinkPad230Csへの
インストール記録 1



その1/準備編
  1. NFSサーバ設定

    AdaptecのSCSIカードやSCSI対応CD-ROMドライブなどを保有していないので今回はネットワークインストールとなりました。(ノートへのインストールとしては一般的なんでしょうね。)で、NFSサーバを仕立てないといけないので、私が持っている唯一のUNIXマシンである、PowerMac7100(MkLinux)の設定から行いました。このMklinuxは別ページにもあるように、RedHatベースで最初にアプリケーションを含め天こ盛りでインストールしてあるのでその時既にNFSサーバも動いていました。

    まず初めに行ったことは、ど素人がNFSを設定するということで、MkLinuxをglobalからprivateへと囲い込むことでした。この辺は、Networking linuxの70ページ以降を参考に、MkLinux(NFS host)が192.168.10.10で、ThinkPadを192.168.10.11としました。でもここからは、今度はMkLinux入門キット(村田暢宏著)の211ページ以降を参考に

    /etc/sysconfig/network
    /etc/sysconfig/network-scripts以下のスクリプトファイル

    で行いました。viで/etc/sysconfig/networkファイルを設定し、/etc/sysconfig/network-scripts/ifcfg-eth0ファイルを作成。設定して保存の後、

    ifup eth0

    で確認という手順です。/etc/hostsファイルに、tp230.mklinux.or.jpを加えて完了。

    # mount -t iso9660 -o ro /dev/cdrom /mnt/cdrom

    でインストールディスクをマウントし、/etc/exportsファイルに

    /mnt/cdrom 192.168.10.11

    を記述してこちらもOK。ところが、Walking Linuxの40ページにあるように

    ps ax | grep rpc

    とすると、MkLinux preDR3では

    # ps ax | grep rpc
    301 ? S 0:00 /usr/sbin/rpc.mountd
    303 ? S 0:00 /usr/sbin/rpc.nfsd

    となり、rpc.portmapがありません。findでさがしても、ファイル自体がないのでこのシステムはこうなのかと開き直って、このままやることに。プロセスをkillして、二つを再起動すると、tp230側から見えたのでこれで良かったみたいです。(素人は怖いですねえ。)

  2. インストール

    使ったディストリビューションはTurboLinux2.0Pro日本語版で、インストール作業は同梱の取説の通りに進めました。順調だったのですが、取説p.23の2-13パーティション設定で実は大ぼけをこいてしまいました。情けないことにfipsなんて知らなかったので、そのままFDISKで

    1 Linux標準 約1,500MB
    2 Linux Swap 約50MB
    3 D0S 約450MB

    としてパーティションを切り直しました。で、元から入っていたWinを消してしまいました。わっはっは。AC電源をつないだまま使っていますが、その時の省電力設定を変更できなくなったので、インストールの途中でバックライトがオフになってしまったり、その後のLinuxの利用でやはり省電力モードになってしまうのがうっとうしいのに、それを変更する術がない状態です。(しかも、Win初心者の私は再インストールができなんですね。ディスクの3のDOS領域もMS-DOSからは読めないようだし、どうなっているのかさっぱりです。

    閑話休題、引き続きインストール作業ですが、2-21-1インストールタイプで「すべて」を選択したので、インストール容量は総計700MBになり、10Base-TのEthernetで4時間かかりました。2-22ビデオカードの自動認識は江後田さんのページでThinkPad内蔵のビデオカードのCirrus6225は上手く行かないことがわかっていましたので、手動でとりあえずそれらしいパラメータを入れていきました。キーボードは日本語106キー、マウスはPS/2、ディスプレイは640x480カラー液晶、8ビットカラーです。ログインはxdmを使わないで標準の方法、時間帯は日本、プリンタは使用せず、etcと続けて行って、問題はliloで起こりました。<マスターブートレコード>、<ブートパーティションの最初のセクタ>、<フロッピーディスクの最初のセクタ>のどれにしても、エラーが発生して設定できません。仕方がないので、この設定はパスしました。このエラーの原因としては、取説のp.128には理由がいくつか書いてあるのですが、BIOS設定をやろうにもLinux以外は起動できないし、リニアモードの方は効果がなかったしということでとりあえず諦めています。ちなみに、取説に書いてあった

    # /sbin/lilo

    も起動後にやってみましたが、効果なしでした。ということで、取説p.126-127に書いてあるブートディスクを用いて起動しないといけない面倒臭い環境です。

  3. 各種設定

    Xを起動してみましたが、江後田さんのページの指摘のようにマウスポインタが右に行くに連れて分裂していく、色が十分に表現されていないなどの症状がでています。上記のページにあるガイドを参考に設定を変更することを検討していますが、今のところ時間が取れていないので、後日ということにしました。


Linuxページに戻る